CanSuppressFirstOrLastBar Method


Checks if the first or last bar in rebar set can be hidden in the given view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public bool CanSuppressFirstOrLastBar(
	View dBView,
	int end
)
Visual Basic
Public Function CanSuppressFirstOrLastBar ( _
	dBView As View, _
	end As Integer _
) As Boolean
Visual C++
public:
bool CanSuppressFirstOrLastBar(
	View^ dBView, 
	int end
)

Parameters

dBView
Type: Autodesk.Revit.DBView
The view in which presentation mode will be applied.
end
Type: SystemInt32
0 for the first bar in rebar set, 1 for the last bar.

Return Value

True the first or last bar in rebar set can be hidden for this view, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also