Identifies if the base geometry of the wall can be represented as an extrusion.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DBElement
The wall or in-place wall element.
- range
- Type: Autodesk.Revit.DB.IFCIFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
- curve
- Type: Autodesk.Revit.DBCurve
The wall's base curve.
Return Value
True if the wall export can be made in the form of an extrusion, false if the geometry cannot be assigned to an extrusion.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |