CanExportWallGeometryAsExtrusion Method


Exporter IFCUtils Can Export Wall Geometry As Extrusion Method

Identifies if the base geometry of the wall can be represented as an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanExportWallGeometryAsExtrusion(
	Element element,
	IFCRange range,
	Curve curve
)

Parameters

element Element
The wall or in-place wall element.
range IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
curve Curve
The wall's base curve.

Return Value

Boolean
True if the wall export can be made in the form of an extrusion, false if the geometry cannot be assigned to an extrusion.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also