GetLeader Method


Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public Leader GetLeader(
	DatumEnds datumEnd,
	View view
)
Visual Basic
Public Function GetLeader ( _
	datumEnd As DatumEnds, _
	view As View _
) As Leader
Visual C++
public:
Leader^ GetLeader(
	DatumEnds datumEnd, 
	View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DBDatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DBView
The view on which the DatumPlane shows.

Return Value

The Leader of the datum plane. Null will return if no leader applied.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This datum plane has no leaders.

See Also