GetLeader Method


Datum Plane Get Leader Method

Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Leader GetLeader(
	DatumEnds datumEnd,
	View view
)

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.

Return Value

Leader
The Leader of the datum plane. Null will return if no leader applied.
Exceptions
Exception Condition
ArgumentException The datum plane cannot be visible in the view.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This datum plane has no leaders.
See Also