IsValidFieldId Method


Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool IsValidFieldId(
	ScheduleFieldId fieldId
)
Visual Basic
Public Function IsValidFieldId ( _
	fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool IsValidFieldId(
	ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DBScheduleFieldId
The field ID to check.

Return Value

True if the field ID is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also