Checks if given type is valid flexible pipe type.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- pipeTypeId
- Type: Autodesk.Revit.DBElementId
ElementId of the flexible pipe type to check.
Return Value
True if flexible pipe type can used for this pipe, false otherwise.Remarks
A type is valid for flexible pipe if it can be used to the flexible pipe element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |