IsFlexPipeTypeId Method


Flex Pipe Is Flex Pipe Type Id Method

Checks if given type is valid flexible pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsFlexPipeTypeId(
	Document document,
	ElementId pipeTypeId
)

Parameters

document Document
The document.
pipeTypeId ElementId
ElementId of the flexible pipe type to check.

Return Value

Boolean
True if flexible pipe type can used for this pipe, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A type is valid for flexible pipe if it can be used to the flexible pipe element.
See Also