Reads the TransmissionData associated with the file at the given location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- path
- Type: Autodesk.Revit.DBModelPath
A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.
Return Value
The TransmissionData containing external file information for the file at the given location.Remarks
The TransmissionData returned by this function contains data about all ExternalFileReferences in the document. ExternalResourceReferences to extenal servers will not be returned by this function. TransmissionData contains information about local or Revit Server references only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsCentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance. |
Autodesk.Revit.ExceptionsCentralModelContentionException | The central model are locked by another client. |
Autodesk.Revit.ExceptionsCentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator. |
Autodesk.Revit.ExceptionsFileArgumentNotFoundException | There is not a valid Revit file at path's location |
Autodesk.Revit.ExceptionsRevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |