Transmission |
Reads the TransmissionData associated with the file at the given location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- path ModelPath
- A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.
Return Value
TransmissionDataThe TransmissionData containing external file information for the file at the given location.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance. |
CentralModelContentionException | The central model are locked by another client. |
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator. |
FileArgumentNotFoundException | There is not a valid Revit file at path's location |
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |

The TransmissionData returned by this function contains data about all ExternalFileReferences in the document. ExternalResourceReferences to extenal servers will not be returned by this function. TransmissionData contains information about local or Revit Server references only.