LoadFrom Method


Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public ExternalResourceLoadStatus LoadFrom(
	ExternalResourceReference desiredResourceReference,
	KeyBasedTreeEntriesLoadResults loadResults
)
Visual Basic
Public Function LoadFrom ( _
	desiredResourceReference As ExternalResourceReference, _
	loadResults As KeyBasedTreeEntriesLoadResults _
) As ExternalResourceLoadStatus
Visual C++
public:
ExternalResourceLoadStatus LoadFrom(
	ExternalResourceReference^ desiredResourceReference, 
	KeyBasedTreeEntriesLoadResults^ loadResults
)

Parameters

desiredResourceReference
Type: Autodesk.Revit.DBExternalResourceReference
An external resource reference describing the source of the desired KeyBasedTreeEntry data.
loadResults
Type: Autodesk.Revit.DBKeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered.

This argument may be a null reference (Nothing in Visual Basic).

Return Value

Returns whether the operation succeeded or failed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. -or- The ExternalResourceReference (desiredResourceReference) is not in a format that is supported by its server.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document containing this KeyBasedTreeEntryTable has no open transaction.

See Also