Key |
Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ExternalResourceLoadStatus LoadFrom(
ExternalResourceReference desiredResourceReference,
KeyBasedTreeEntriesLoadResults loadResults
)
Parameters
- desiredResourceReference ExternalResourceReference
- An external resource reference describing the source of the desired KeyBasedTreeEntry data.
- loadResults KeyBasedTreeEntriesLoadResults
-
If provided, Revit will use this object to store any errors or warnings that were encountered.
This argument may be .
Return Value
ExternalResourceLoadStatusReturns whether the operation succeeded or failed.

Exception | Condition |
---|---|
ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. -or- The ExternalResourceReference (desiredResourceReference) is not in a format that is supported by its server. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction. |