Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- MEPPartId
- Type: Autodesk.Revit.DBElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
- description
- Type: SystemString
The description of the rule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |