RoutingPreferenceRule Constructor


Routing Preference Rule Constructor

Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RoutingPreferenceRule(
	ElementId MEPPartId,
	string description
)

Parameters

MEPPartId ElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
description String
The description of the rule.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also