Multiplies this transformation by the specified transformation and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- right
- Type: Autodesk.Revit.DBTransform2D
Return Value
The transformation equal to the composition of the two transformations.Remarks
The combined transformation has the same effect as applying the right transformation first, and this transformation, second. So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |