Transform |
Multiplies this transformation by the specified transformation and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- right Transform2D
Return Value
Transform2DThe transformation equal to the composition of the two transformations.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The combined transformation has the same effect as applying the right transformation first, and this transformation, second. So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).