Creates a new instance of a Rebar Coupler element within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
A document.
- typeId
- Type: Autodesk.Revit.DBElementId
type id for coupler
- pFirstData
- Type: Autodesk.Revit.DB.StructureReinforcementData
information about the first reinforcement to be coupled
- pSecondData
- Type: Autodesk.Revit.DB.StructureReinforcementData
information about the second reinforcement to be coupled; if a nullptr is passed in the coupler is placed on one reinforcement
- error
- Type: Autodesk.Revit.DB.StructureRebarCouplerError%
will be ValidationSuccesfully(0) if ok, otherwise the failure reason
Return Value
The newly created Rebar Coupler instance, or a null reference (Nothing in Visual Basic) if the operation fails.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |