Rebar |
Creates a new instance of a Rebar Coupler element within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RebarCoupler Create(
Document doc,
ElementId typeId,
ReinforcementData pFirstData,
ReinforcementData pSecondData,
out RebarCouplerError error
)
Parameters
- doc Document
- A document.
- typeId ElementId
- type id for coupler
- pFirstData ReinforcementData
- information about the first reinforcement to be coupled
- pSecondData ReinforcementData
- information about the second reinforcement to be coupled; if a nullptr is passed in the coupler is placed on one reinforcement
- error RebarCouplerError
- will be ValidationSuccesfully(0) if ok, otherwise the failure reason
Return Value
RebarCouplerThe newly created Rebar Coupler instance, or if the operation fails.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |