Creates a new curve loop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curves
- Type: System.Collections.GenericIListCurve
The curves.
Return Value
The curve loop.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |