Create Method


Curve Loop Create Method

Creates a new curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveLoop Create(
	IList<Curve> curves
)

Parameters

curves IList Curve
The curves.

Return Value

CurveLoop
The curve loop.
Exceptions
Exception Condition
ArgumentException The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous.
ArgumentNullException A non-optional argument was null
See Also