NewProjectDocument Method


New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Document NewProjectDocument(
	string templateFileName
)
Visual Basic
Public Overridable Function NewProjectDocument ( _
	templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
	String^ templateFileName
)

Parameters

templateFileName
Type: SystemString
The template file name.

Remarks

This command corresponds to New->Project command in the user-interface.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionIf 'templateFileName' is a null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.ExceptionsInvalidOperationExceptionIf the new project document cannot be created.

See Also