NewProjectDocument Method


Application New Project Document(String) Method

New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual Document NewProjectDocument(
	string templateFileName
)

Parameters

templateFileName String
The template file name.

Return Value

Document
Exceptions
Exception Condition
ArgumentException If 'templateFileName' is or an empty string.
InvalidOperationException If the new project document cannot be created.
Remarks
This command corresponds to New->Project command in the user-interface.
See Also