Distance Property


The illuminance intensity distance value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
	Get
	Set
Visual C++
public:
property double Distance {
	double get ();
	void set (double value);
}

Field Value

The illuminance distance value in feet as a numerical value between 0 and 1e+30.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The distance value is not valid because it is not between 0 and 1e+30.

See Also