CheckBuildingHVACSystem Method


Checks that the building HVAC system falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool CheckBuildingHVACSystem(
	gbXMLBuildingHVACSystem buildingHVACSystem
)
Visual Basic
Public Shared Function CheckBuildingHVACSystem ( _
	buildingHVACSystem As gbXMLBuildingHVACSystem _
) As Boolean
Visual C++
public:
static bool CheckBuildingHVACSystem(
	gbXMLBuildingHVACSystem buildingHVACSystem
)

Parameters

buildingHVACSystem
Type: Autodesk.Revit.DB.AnalysisgbXMLBuildingHVACSystem
The building HVAC system to be checked.

Return Value

True if the building HVAC system falls within an appropriate range, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also