Energy |
Checks that the building HVAC system falls within an appropriate range.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CheckBuildingHVACSystem(
gbXMLBuildingHVACSystem buildingHVACSystem
)
Parameters
- buildingHVACSystem gbXMLBuildingHVACSystem
- The building HVAC system to be checked.
Return Value
BooleanTrue if the building HVAC system falls within an appropriate range, false otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |