Repositions the fabrication straight part to another end of the run.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- partId
- Type: Autodesk.Revit.DBElementId
Identifier of the fabrication part to reposition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | It is not a straight segment on the end in the run. -or- There are locked parts in the run. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | this operation failed. |