Reposition Method


Fabrication Part Reposition Method

Repositions the fabrication straight part to another end of the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void Reposition(
	Document document,
	ElementId partId
)

Parameters

document Document
The document.
partId ElementId
Identifier of the fabrication part to reposition.
Exceptions
Exception Condition
ArgumentException It is not a straight segment on the end in the run. -or- There are locked parts in the run.
ArgumentNullException A non-optional argument was null
InvalidOperationException this operation failed.
See Also