Among those rebar shapes defined by an arc, specify which kind.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This property may be explicitly set to Arc or LappedCircle. But to set the property to Spiral, you must call SetArcTypeSpiral() and provide default values for the height, pitch, and finishing turns.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |