Rebar |
Among those rebar shapes defined by an arc, specify which kind.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Property Value
RebarShapeDefinitionByArcType
Exception | Condition |
---|---|
ArgumentException | When setting this property: The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters. |
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |

This property may be explicitly set to Arc or LappedCircle. But to set the property to Spiral, you must call SetArcTypeSpiral() and provide default values for the height, pitch, and finishing turns.