Voltage Property


The voltage value of the analytical bus.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public double Voltage { get; set; }
Visual Basic
Public Property Voltage As Double
	Get
	Set
Visual C++
public:
property double Voltage {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The given value for voltage is not a number -or- When setting this property: The given value for voltage is not finite
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The given value for voltage must be positive.

See Also