Analytical |
Note: This API is now obsolete.
The voltage value of the analytical bus.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The voltage is read only in Revit 2025 and assigned through the distribution system of the analytical bus, we suggest you use the 'AssignedVoltage' property instead.")]
public double Voltage { get; set; }
Property Value
Double
Exception | Condition |
---|---|
ArgumentException | When setting this property: The given value for voltage is not a number -or- When setting this property: The given value for voltage is not finite |
ArgumentOutOfRangeException | When setting this property: The given value for voltage must be positive. |
InvalidOperationException | When setting this property: The voltage on the analytical node is not editable. |