Checks if contour loops is inside host boundaries.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
Document.
- hostId
- Type: Autodesk.Revit.DBElementId
The id of the analytical element that is about to host a load
- loops
- Type: System.Collections.GenericIListCurveLoop
CurveLoops to be checked.
Return Value
Returns true if area load is positioned with entire distribution over the host, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |