Area |
Checks if contour loops is inside host boundaries.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsCurveLoopsInsideHostBoundaries(
Document doc,
ElementId hostId,
IList<CurveLoop> loops
)
Parameters
- doc Document
- Document.
- hostId ElementId
- The id of the analytical element that is about to host a load
- loops IList CurveLoop
- CurveLoops to be checked.
Return Value
BooleanReturns true if area load is positioned with entire distribution over the host, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |