InsertField Method (SchedulableField, Int32)


Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public ScheduleField InsertField(
	SchedulableField schedulableField,
	int index
)
Visual Basic
Public Function InsertField ( _
	schedulableField As SchedulableField, _
	index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
	SchedulableField^ schedulableField, 
	int index
)

Parameters

schedulableField
Type: Autodesk.Revit.DBSchedulableField
A SchedulableField object representing the field.
index
Type: SystemInt32
The index in the list of fields.

Return Value

The new field.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException index is not a valid insert position.

See Also