InsertField Method (SchedulableField, Int32)


Schedule Definition Insert Field(Schedulable Field, Int 32) Method

Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ScheduleField InsertField(
	SchedulableField schedulableField,
	int index
)

Parameters

schedulableField SchedulableField
A SchedulableField object representing the field.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception Condition
ArgumentException The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid insert position.
See Also