GetBearerExtension Method


Gets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public double GetBearerExtension(
	int rodIndex
)
Visual Basic
Public Function GetBearerExtension ( _
	rodIndex As Integer _
) As Double
Visual C++
public:
double GetBearerExtension(
	int rodIndex
)

Parameters

rodIndex
Type: SystemInt32
The index of the rod.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
Autodesk.Revit.ExceptionsInvalidOperationException The hanger is not a bearer hanger.

See Also