Returns the major side faces for this host object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostObject
- Type: Autodesk.Revit.DBHostObject
The host object.
- side
- Type: Autodesk.Revit.DBShellLayerType
The side of the host object.
Return Value
An array of references to the faces which are on the given side of this element.Remarks
This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This host object does not support access to side faces. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |