GetSideFaces Method


Host Object Utils Get Side Faces Method

Returns the major side faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<Reference> GetSideFaces(
	HostObject hostObject,
	ShellLayerType side
)

Parameters

hostObject HostObject
The host object.
side ShellLayerType
The side of the host object.

Return Value

IList Reference
An array of references to the faces which are on the given side of this element.
Exceptions
Exception Condition
ArgumentException This host object does not support access to side faces.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).
See Also