CreateSpatialFieldManager Method


Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static SpatialFieldManager CreateSpatialFieldManager(
	View view,
	int numberOfMeasurements
)
Visual Basic
Public Shared Function CreateSpatialFieldManager ( _
	view As View, _
	numberOfMeasurements As Integer _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ CreateSpatialFieldManager(
	View^ view, 
	int numberOfMeasurements
)

Parameters

view
Type: Autodesk.Revit.DBView
View for which manager object is created or retrieved
numberOfMeasurements
Type: SystemInt32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

Manager object for the view passed in the argument

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException numberOfMeasurements is less than one
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException View is not allowed to display analysis results or a manager object for this view already exists

See Also