CreateSpatialFieldManager Method


Spatial Field Manager Create Spatial Field Manager Method

Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static SpatialFieldManager CreateSpatialFieldManager(
	View view,
	int numberOfMeasurements
)

Parameters

view View
View for which manager object is created or retrieved
numberOfMeasurements Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

SpatialFieldManager
Manager object for the view passed in the argument
Exceptions
Exception Condition
ArgumentException numberOfMeasurements is less than one
ArgumentNullException A non-optional argument was null
InvalidOperationException View is not allowed to display analysis results or a manager object for this view already exists
See Also