HasCircuitsWithoutElectricalLoadAreas Method


Checks whether there are any empty plan circuits in which there are no electrical load areas.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static bool HasCircuitsWithoutElectricalLoadAreas(
	Document doc,
	ElementId levelId,
	ElementId phaseId
)
Visual Basic
Public Shared Function HasCircuitsWithoutElectricalLoadAreas ( _
	doc As Document, _
	levelId As ElementId, _
	phaseId As ElementId _
) As Boolean
Visual C++
public:
static bool HasCircuitsWithoutElectricalLoadAreas(
	Document^ doc, 
	ElementId^ levelId, 
	ElementId^ phaseId
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document to check.
levelId
Type: Autodesk.Revit.DBElementId
The base level on which the empty plan circuits to check.
phaseId
Type: Autodesk.Revit.DBElementId
The associated phase in which the empty plan circuits to check.

Return Value

True if there are empty plan circuits in which there are no electrical load areas, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException doc is not a project document. -or- The ElementId levelId is not a Level. -or- The id does not represent a valid phase.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).

See Also