HasCircuitsWithoutElectricalLoadAreas Method


Electrical Load Area Data Has Circuits Without Electrical Load Areas Method

Checks whether there are any empty plan circuits in which there are no electrical load areas.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool HasCircuitsWithoutElectricalLoadAreas(
	Document doc,
	ElementId levelId,
	ElementId phaseId
)

Parameters

doc Document
The document to check.
levelId ElementId
The base level on which the empty plan circuits to check.
phaseId ElementId
The associated phase in which the empty plan circuits to check.

Return Value

Boolean
True if there are empty plan circuits in which there are no electrical load areas, false otherwise.
Exceptions
Exception Condition
ArgumentException doc is not a project document. -or- The ElementId levelId is not a Level. -or- The id does not represent a valid phase.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also