IsRectangular Method


Identifies if the curve loop is rectangular with respect to a given projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public bool IsRectangular(
	Plane plane
)
Visual Basic
Public Function IsRectangular ( _
	plane As Plane _
) As Boolean
Visual C++
public:
bool IsRectangular(
	Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DBPlane
The plane to which the curves will be projected to determine if they represent a rectangle.

Return Value

True if the curve loop is rectangular, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also