IsRectangular Method


Curve Loop Is Rectangular Method

Identifies if the curve loop is rectangular with respect to a given projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsRectangular(
	Plane plane
)

Parameters

plane Plane
The plane to which the curves will be projected to determine if they represent a rectangle.

Return Value

Boolean
True if the curve loop is rectangular, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also