Connects placeholders that looks like elbow connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- connector1
- Type: Autodesk.Revit.DBConnector
The first end connector of placeholder to be connected to.
- connector2
- Type: Autodesk.Revit.DBConnector
The second end connector of placeholder to be connected to.
Return Value
True if connection succeeds, false otherwise.Remarks
The placeholders may have physical connection or may not connect at all. In the latter case, the first one connects to the end of second one. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |