Plumbing |
Connects placeholders that looks like elbow connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool ConnectPipePlaceholdersAtElbow(
Document document,
Connector connector1,
Connector connector2
)
Parameters
- document Document
- The document.
- connector1 Connector
- The first end connector of placeholder to be connected to.
- connector2 Connector
- The second end connector of placeholder to be connected to.
Return Value
BooleanTrue if connection succeeds, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. |
ArgumentNullException | A non-optional argument was null |

The placeholders may have physical connection or may not connect at all. In the latter case, the first one connects to the end of second one. If connection fails, the placeholders cannot be physically connected.