Create a new RibbonPanel on the specified tab.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- tabName
- Type: SystemString
The name of the tab, on which the new panel will be created.
- panelName
- Type: SystemString
The name of the panel to be created.
Remarks
This method will create a custom panel appending to the specified tab. This method is not supported in Macros.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | tabName or panelName is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | tabName or panelName is Empty. |
Autodesk.Revit.ExceptionsInvalidOperationException | Too many panels have been added to this tab (Maximum is 100). |