CreateRibbonPanel Method (String, String)


UIApplication Create Ribbon Panel(String, String) Method

Create a new RibbonPanel on the specified tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual RibbonPanel CreateRibbonPanel(
	string tabName,
	string panelName
)

Parameters

tabName String
The name of the tab, on which the new panel will be created.
panelName String
The name of the panel to be created.

Return Value

RibbonPanel
Exceptions
Exception Condition
ArgumentNullException tabName or panelName is .
ArgumentException tabName or panelName is Empty.
InvalidOperationException Too many panels have been added to this tab (Maximum is 100).
Remarks
This method will create a custom panel appending to the specified tab. This method is not supported in Macros.
See Also