Inserts a (key, info) pair into Export line type table.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exportLinetypeKey
- Type: Autodesk.Revit.DBExportLinetypeKey
The export line type Key to be added.
- exportLinetypeInfo
- Type: Autodesk.Revit.DBExportLinetypeInfo
The export line type info to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The key already exists in the table. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |