Add Method


Export Linetype Table Add Method

Inserts a (key, info) pair into Export line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Add(
	ExportLinetypeKey exportLinetypeKey,
	ExportLinetypeInfo exportLinetypeInfo
)

Parameters

exportLinetypeKey ExportLinetypeKey
The export line type Key to be added.
exportLinetypeInfo ExportLinetypeInfo
The export line type info to be added.
Exceptions
Exception Condition
ArgumentException The key already exists in the table.
ArgumentNullException A non-optional argument was null
See Also